小萌羽w

Cisco路由交换配置及技术交流(随时更新)
记录下自己网工之路,每次实践操作后会写好配置教程在此供大家参考交流学习,感兴趣的可以留言交流,若有错误请务必指出。...
扫描右侧二维码阅读全文
16
2019/06

Cisco路由交换配置及技术交流(随时更新)

记录下自己网工之路,每次实践操作后会写好配置教程在此供大家参考交流学习,感兴趣的可以留言交流,若有错误请务必指出。

头图地址:hide and seek

静态路由

简单的例子:

静态路由.png

首先将机器连好后配好对应的地址和子网完成基本的连接,这里的loopback接口就是本地回环接口,用于测试连通性的虚拟接口。
这里配的是1.1.1.1和3.3.3.3地址的loopback接口,目的是为了1.1.1.0网段能够与3.3.3.0网段实现相互通信,完成设置后我们在R1上尝试ping 3.3.3.3地址会出现以下信息

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

这代表数据是不可通的,因为目前是直连路由路由表里只有192.168.1.0/24的直连路由信息,而我们要到达的目标网段是3.3.3.0/24,因此要进行配置路由表从而达到目的。

静态路由配置方法(写入到路由表):

**Router(config)#ip route <目标网段> <目标子网掩码> <下一跳接口地址>**

我们从1.1.1.1要发送数据包给3.3.3.3的话,必须要让R1知道转发到下个设备某个的接口上去,因此要在路由表添加相对应的传送路径,如图所示的配置信息,我们进行以下配置:

R1(config)#ip route 3.3.3.0 255.255.255.0 192.168.1.254

之后在show ip route就可以看到对应的信息写到了路由表

S       3.3.3.0 [1/0] via 192.168.1.253 #S表示是静态路由配置的路径

接下来数据包从R2的F0/0入口进来了,因为R2也只有连接192.168.1.0/24和192.168.2.0/24的直连路由并没有到达3.3.3.0网段的路径所以这个包到了R2这因对应转发规则而被抛弃,因为R1使用ICMP的ping程序 ping了3.3.3.3地址,当数据包被R2丢弃后R2会反馈一个路径目标不可达信息给R1.

所以之后我们要在R2上添加路径从而让包到达R3上的loopback接口地址上

R2(config)#ip route 3.3.3.0 255.255.255.0 192.168.2.253

写入成功后则R1的数据包能到达了目标地址

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
.U.U.
Success rate is 0 percent (0/5)

但是为什么还是会显示ping不通的情况? 因为ping需要一个返回包来通告然而在R3和R2上没有回到1.1.1.0网段上的路径自然也就没有返回消息了返回目标不可达信息。

接下来和上面一样我们在R3和R2上配置到1.1.1.0网段的路径

R2:
R2(config)#ip route 1.1.1.0 255.255.255.0 192.168.1.254

R3:
R3(config)#ip route 1.1.1.0 255.255.255.0 192.168.2.254

show ip route确认路由表正确写入后
在尝试ping对应ip检查是否能够通信,用1.1.1.1去ping 3.3.3.3后返回以下信息


Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.0, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms

可以看到有了!表示能正常通信了,第一次成功通信可能会出现"."丢包这是代表路由之间在使用ARP解析获取对应信息,3.3.3.3 此时也能ping通了 1.1.1.1说明两个网段间全网通信了

VLAN技术

技术简介:
VLAN(Virtual Local Area Network)指的是虚拟化局域网,因为在一二层设备间会存在广播风暴和介质争用的现象,我们要试图减小这些影响网络效率的影响,增加网络设备来分割大型冲突域势必会导致成本过高,所以后来在交换机的上产生了VLAN分割网络的技术将一个大型冲突域划分为一个个小的冲突域从而减小成本提高效率,也使得网络可以有良好的拓展性

基本配置方法介绍:
这里以一个简单的拓扑来讲解

基础设备:2台路由器以及若干台pc

VLAN技术.png

建立好一个网络环境后,先看一看此时网络环境的状况,两台交换机分别接上了4台PC,在没有任何操作的情况下各PC间可以相互进行通信,第一次通信会发出ARP请求解析设备交换机则会将ARP请求包广播转发,此网络环境下的所有的主机都会接到并查看与自生是否对应从而选择应该丢弃还是应答,如果这时候大量的请求在网络上传播势必会造成大量不必要的资源消耗,将其划分为小的局域网是最好的选择。

我们在交换机上配置vlan来划分网络区域

Cisco IOS中有两种方式创建vlan,在全局模式下使用vlan <vlanid>命令,或在特权模式下在vlan database 下创建vlan;

注意事项:一个交换机的任何端口都必须属于且只能属于一个VLAN

这里用的是在全局模式下设置,首先确定要划分的端口连接情况,这里将PC0和PC1作为一个区域划分
连接的交换机配置方法:

S1(config)#vlan 10  #创建vlan号为10的vlan区域
S1(config-vlan)#name vlan10    #命名为vlan10
S1(config)#interface range f0/1-2    #以组的形式配置端口0/1和f0/2
S1(config-if-range)#switchport access vlan 10    #将这些端口划分到创建的vlan 10下
S1(config-if-range)#no shutdown     #启用端口

switchport access中access是交换机端口的一种类型,其在同一时刻只能存在于一个vlan里,而且其不允许带有vlan标签的帧通过,默认为access类型

这样子就已经划分好了一个命为vlan10的虚拟局域网区域,原本PC0可以ping通PC3,现在我们尝试再ping一次会发现出现了requests time out的返回

连通情况1.jpg

这说明已经不可通信了,为什么不能通信呢?这是因为将端口划分到VLAN下时所有经过此端口的数据包都会被打上VLAN10的标签(tag),路由器会根据自身查找对应vlan标签的端口进行转发并且PC设备不支持处理这些vlan标签也就丢弃了,我们尝试ping相同vlan下的设备地址会发现是可以正常通信

连通性2.jpg

也就证明了在相同vlan下不做额外处理的情况下,只有相同vlan区域的设备才能互相通信其他的数据包都将会被丢弃。此时我们在S1交换机右边配置vlan20后也会是相同的情况。

如果只是这样划分出小局域网而各个小局域网之间不能互相通信的话对于网络数据发送来说也不是件好事,当然交换机上也有别的方法处理这个问题,那就是Trunk端口类型

Trunk类型的特性:

允许多个VLAN通过,可以接收和发送多个VLAN的数据帧

Native VLAN(本地VLAN)的以太网帧不带标签

一般用于交换机之间或交换机与路由连接

在trunk端口,若收到没有任何VLAN信息的帧,默认该帧是native VLAN帧;
在trunk端口,只有native VLAN帧可以不带标签转发;
允许通过的VLAN:在trunk链路上,可以带着标签转发的VLAN信息,默认是all;
禁止通过的VLAN:不允许在trunk链路上传输的VLAN信息帧;

当端口配置成trunk干线后,该端口就失去了它自身的VLAN标识,可以为该交换机内的所有VLAN传输数据

Trunk端口发送数据帧的动作:

1.首先比较该帧的VLAN信息和本端口的native VLAN信息是否相同;

2.若相同,剥离VLAN标签转发

3.若不同,查看该VLAN是非在允许通过的VLAN范围内

4.若在允许通过的范围内,带着VLAN标签转发

5.若不在范围内,直接丢弃

配置方法:

在S1上配置时因为之前已经划分过vlan区域了只需要将对应VLAN下端口类型改为Trunk口即可使得S1两边的VLAN互相通信

在有VLAN配置下:
S1(config)#interface <端口>  #进入端口
S1(config-if-range)#switchport mode trunk   #将交换机端口类型更改为Trunk类型


先前无划分VLAN的端口下配置:
S1(config)#interface <端口>     #进入端口
S1(config-if)#switchport access vlan <id>     #将端口划分到创建的vlan <id>下
S1(config-if)#switchport mode trunk    #将交换机端口类型更改为Trunk类型
S1(config-if)#no shutdown   #启用端口

此时S1交换机两边可以互相通信了,于是我们在下面S2上也做相同的配置,那么两边有两个一样的VLAN10和VLAN20,那么是不是下面的发送的数据包也能到达上面的设备上呢,经过测试是不行的

在交换机相互连接的端口上并没有配置为Trunk类型,所以下面的VLAN是无法与上面的一样的VLAN区域进行相互通信的,如果要通信的话需要在交换机互相连接的端口上配置Trunk类型

S2(config)#interface g0/1
S2(config-if)#switchport mode trunk

S1(config)#interface g0/1
S1(config-if)#switchport mode trunk

这样上下的VLAN就可以相互通信了,如果要限制哪些vlan可以通过trunk口出的话用switchport trunk allowed vlan <id>,<id>即可,记得交换机本身就是个VLAN1哦~~~~(踩了坑)

DHCP服务配置

DHCP.png

1.给与交换机连接的接口配置IP地址
DHCP(config)# int f0/0
DHCP(config-if)# ip address 192.168.1.1 255.255.255.0
这个地址作为整个网络的网关

2.配置DHCP服务
DHCP(config)# service dhcp # 开启DHCP服务
DHCP(config)# ip dhcp pool dhcp1 # 创建地址池dhcp1
DHCP(dhcp-config)# network 192.168.1.0 255.255.255.0 # 确认地址池的网段
DHCP(dhcp-config)# default-router 192.168.1.1 # 确认默认网关
DHCP(dhcp-config)# dns-server 114.114.114.114 # 确认DNS服务器
DHCP(dhcp-config)#exit

3.配置不分配的IP地址
192.168.1.0/24 这个地址池总共有254个地址
192.168.1.1已经分配给了默认网关
所以接下来分配的地址是:192.168.1.2 - 192.168.1.254
我们可以使用ip dhcp excluded-address 这个命令排除不想分配的地址

DHCP(config)#ip dhcp excluded-address 192.168.1.1 # 排除单个地址
DHCP(config)#ip dhcp excluded-address 192.168.1.2 192.168.1.10 # 排除一段地址

Last modification:June 22nd, 2019 at 02:58 pm
If you think my article is useful to you, please feel free to appreciate

Leave a Comment