VLAN中继协议,也被称为虚拟局域网干道协议。VTP技术是一种用于集中化管理VLAN信息的一种技术,主要作用于管理在同一个域的网络范围内VLANs的建立,在多网络交换设备中单独一个个为每台设备配置VLAN信息过于繁琐低效。利用VTP的VLAN中继协议就可以在一台主服务器上配置好VLAN将其他设备加入进域里统一获取主服务器的VLAN信息实现自动配置管理,从而高效的搭建网络。

VTP的三种模式:

  1. VTP Server(VTP服务器)
  2. VTP Client(VTP客户端)
  3. VTP Transparent(透明模式)

VTP各模式下的角色责任:

  1. VTP Server(VTP服务器)
    VTP Server为整个VTP交换网络中的主服务器用于管理域名和VLAN的配置信息server模式下的设备会参与到整个VTP交换网络 将自己的VLAN信息更新后发出给其他的设备接收在server模式的设备重启时会将全局VLAN保存至NVRAM里不会缺失且VTP的配置 更改 删除等信息会被更新
  1. VTP Client(VTP客户端)
    VTP Clinet作为客户端来说 主要职责就是学习接收来自主VTP服务器发送的VTP信息并与自身原本的VTP配置信息进行比对若自身的VLAN信息与主服务器发送的信息不一致时 放弃自身的配置信息转而学习主服务器的信息为准来更新自身VTP配置同样 Client端也是参与进整个交换网络。区别于Server模式下,client端一旦重启设备会丢失全局VLAN信息 Client端的全局VLAN是运行在RAM上的一旦重启则会清空RAM,直到设备重启后再次接收学习server端发来的VTP信息 来更新
  1. VTP Transparent(透明模式)
    VTP Transparent模式下相比其他两个 配置此模式的设备将只会作为一个中继转发作用,既不会学习server发来的VTP信息 也不会将自身的VTP消息传播到整个网络中所以Transparent模式下 只会更新本地手动配置的VTP而不是学习VTP消息来配置,VTP的信息不会被更新当设备重启时,不会保存全局VLAN,其VLAN配置文件信息只保存在NVRAM里,VTP的信息不会被更新。

在使用VTP协议时必须明确:

  1. 在server机上配置好域名和密码后 Client & Transparent 模式下也必须配置与其相同的域名和密码 否则将无法同处一个域中接收转发消息
  2. 端口为Trunk模式(VTP是一个基于Trunk链路的协议)
  3. 默认配置下所有客户端均运行server模式

当设备开始运行VTP时会发送VTP Advertisements (公告)包含一下信息

  1. Summary advertisements
  2. Advertisement request

在Summary advertisements消息中会将VTP具体的domain name以及当前VTP的 revision number发送使接收端确认当前域名修正当前的版本修订号

Advertisement request消息是客户端在当修订版本号对比当前版本高时 响应 Summary advertisements的报文信息来更新

Subset advertisements 包含客户端所需VLAN更新的信息

实验演示

topology.jpg

查看server,client以及 transparent设备端的各个vlan情况

server端:

server vlan brief.jpg

client 以及 transparent端:

client vlan brief.jpg

配置步骤

    server端:
    Switch(config)#vtp mode server
    Switch(config)#vtp domain ccna3
    Switch(config)#vtp password ccna123 
    Switch(config)#interface f0/24
    Switch(config-if)#switchport mode trunk
    Switch(config-if)#no shutdown
    client端:
    Switch(config)#vtp mode client
    Switch(config)#vtp domain ccna3   ----(domain same as server)
    Switch(config)#vtp password ccna123   ----(same of server set password)
    Switch(config)#interface f0/24    ----(进入对应连接的端口)
    Switch(config-if)#switchport mode trunk    ----(设置trunk链路模式)
    Switch(config-if)#no shutdown
    
    此处省略s2client与transparent f0/23端口配置命令 同理配置trunk链路即可
    transparent端:
    Switch(config)#vtp mode transparent
    Switch(config)#vtp domain ccna3   ----(domain same as server)
    Switch(config)#vtp password ccna123   ----(same of server set password)
    Switch(config)#interface range f0/23-24
    Switch(config-if-range)#switchport mode trunk
    Switch(config-if-range)#no shutdown

配置完后等待链路连通后再次查看vlan信息

server:

server vlan brief.jpg

client:

learn VTP.jpg

transparent:

client vlan brief.jpg

transparent的VLAN信息保持自身外 client端均学习同步server的VTP发来的VLAN信息

Last modification:April 7th, 2020 at 08:21 am
如果觉得我的文章对你有用,请随意赞赏